Upgrade Oracle opatch Version

Upgrade Oracle opatch Version

Get Social!

opatch-upgrade-requiredopatch is Oracle’s tool for patching software such as OBIEE and ODI and is used in conjunction with patch downloads from Oracle Support.

Versions of the opatch tool change over time, often in line with releases of other Oracle software. If you try to use an out of date opatch binary for a newer patch file, you’ll get the below error.

You need to upgrade your version of opatch to the OUI Version indicated, which in this example is 11.2.0.1.0.

To upgrade your version of opatch search on Oracle Support for patch number 6880880 and click one of the results – there are several results titled something similar to ‘OPatch patch of version 11.1.0.12.7 for Oracle software releases 11.1.0.x (JUN 2015) (Patch)‘. You can click on any of the results with a similar name to the above as they all take you to the same page.

opatch-download-verisonOn the top left of the page, select the Release of opatch you need along with the the Platform you will be using opatch on and then click Download.

Copy the downloaded patch file to your target machine and unzip the file.

Installing the updated opatch binary is simple – move the old OPatch directory and replace it with the new one we just downloaded.

For this example, we’re replacing the OPatch folder for an OBIEE installation located at /u01/app/oracle/product/fmw/Oracle_BI1/. Depending on your install path and application, your path may be different however the OPatch directory is usually found in the ORACLE_HOME directory.

Copy the unzipped OPatch folder to the ORACLE_HOME directory:

Check the version of the opatch binary:

 

 


Visit our advertisers

Search

Quick Poll

What type of VPN protocol do you use?

Visit our advertisers